読者です 読者をやめる 読者になる 読者になる

日々精進

新しく学んだことを書き留めていきます

Elipseでビルドする際のJVMのターゲットバージョンを変更する

Eclipse全体の設定は以下のように行う。

Eclipse メニューから「ウィンドウ」>「設定」を選択し、「設定」ダイアログを開きます。
「Java」>「コンパイラー」を選択し、表示された画面で「コンパイラー準拠レベル」を選択します。

但し、既に作成済みのプロジェクトのターゲットバージョンは上記手順では変わらなかった。 以下手順で変更出来た。

プロジェクトエクスプローラーでプロジェクトを右クリック > プロジェクトの設定ダイアログで「Java」>「コンパイラー」を選択し、表示された画面で「コンパイラー準拠レベル」を選択します。

二箇所設定出来るところがあるとは知らず、はまった。。

参考:

www.hitachi.co.jp