読者です 読者をやめる 読者になる 読者になる

日々精進

新しく学んだことを書き留めていきます

モデル作成でエラー

IT Rails

Rails2.3.5にアップデート後、初めてモデルを作ろうとしたら、エラー。

./script/../config/../vendor/rails/railties/lib/initializer.rb:271:in `require_frameworks': RubyGem version error: rack(1.0.0 not ~> 1.0.1) (RuntimeError)

だって。エラーメッセージで検索すると↓のページが見つかりました。
http://d.hatena.ne.jp/nya0/20100319/p1
Rack1.0.1をインストールすれば直るらしいけど、なんかバッドノウハウな感じで嫌だなぁ。
渋々Rack1.0.1をインストール。

gem install rack --version '=1.0.1'

再度モデルを生成したら今度はlibmysql.dllが無いと怒られる。
検索したら普通にC:\Rails\mysql\binにある。パスが通ってなかっただけか。
パスを通したら無事実行できました。オープンソースフレームワークはこういう小さな躓きが多いので大変だなあ。(libmysql.dllの件はOSSのせいじゃないけど。)